Ask Your Question
0

Not able to build the wireshark

asked 2017-12-11 08:50:43 +0000

updated 2017-12-11 11:33:29 +0000

grahamb gravatar image

Hi,

Iam trying to build the wireshark in my windows 7 machine with Qt 5.10.0 and Visual Studio community 2015 version.I followed the Win32/64: Step-by-Step Guide for the same.It is able to build the files till the section (2.2.10. Generate the build files).

But i tried the build the wireshark using the command (msbuild /m /p:Configuration=RelWithDebInfo Wireshark.sln) it throws 240 errors regrading the compiler versions.

it is failing like this(below is the last part of the log file)

   C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\extcap_argument_multiselect.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\extcap_argument_file.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\expert_info_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\extcap_options_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\gsm_map_summary_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\mtp3_summary_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\funnel_statistics.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\io_graph_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does not seem to be that. (C:\Development\wireshark\ui\qt\multicast_statistics_dialog.cpp) [C:\Development\wsbuild32\ui\qt\qtui.vcxproj]
         C:\Qt\5.10.0\msvc2017_64\include\QtCore/qcompilerdetection.h(567): fatal error C1189: #error :  Qt requires a C++11 compiler and yours does ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-12-11 10:27:53 +0000

grahamb gravatar image

From the paths show it would seem that you have downloaded\installed Qt for use with VS 2017. You must match the build of Qt with the version of Visual Studio you are using.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-11 08:50:43 +0000

Seen: 234 times

Last updated: Dec 11 '17