Ask Your Question
0

No CMAKE_C(XX)_COMPILER could be found

asked 2017-12-06 19:30:49 +0000

qutefu gravatar image

updated 2017-12-07 15:46:21 +0000

grahamb gravatar image

I try to compile wireshark in my windows(10) PC, Follow the instruction https://www.wireshark.org/docs/wsdg_html_chunked/ChSetupWin32.html#ChWin32Generate, I have setup the working environment,

set WIRESHARK_BASE_DIR=C:\Users\Me\DDisk\FWork\WireShark\  
set QT5_BASE_DIR=C:\Qt\Qt5.6.3\5.6.3\msvc2015_64  
set WIRESHARK_VERSION_EXTRA=-1.0.0  
set WIRESHARK_CYGWIN_INSTALL_PATH=C:\cygwin64  
set VisualStudioVersion=14.0

Visual Studio 2015, QT, Cygwin, python, git and cmake have been installed.

NOTE: I have VS2005 before, for the Wireshark compiling, I remove it after VS2015 has been installed, the removing may be unclear.

When I run the command at VS2015 command prompt: cmake -DENABLE_CHM_GUIDES=on -G "Visual Studio 14 2015 Win64" ..\wireshark

I got the following result:

-- The C compiler identification is unknown
-- The CXX compiler identification is unknown

CMake Error at CMakeLists.txt:22 (project):

No **CMAKE__C__COMPILER** could be found.

CMake Error at CMakeLists.txt:22 (project):
  No **CMAKE__CXX__COMPILER** could be found.

-- Configuring incomplete, errors occurred!
See also "C:/Users/Me/DDisk/FWork/WireShark/wsbuild64/CMakeFiles/CMakeOutput.log".
See also "C:/Users/Me/DDisk/FWork/WireShark/wsbuild64/CMakeFiles/CMakeError.log".

If you have any experience or idea about it, please help me. Thanks in advance!

edit retag flag offensive close merge delete

Comments

my QT version is 5.6.3, is it a reason for the error? Since I found QT version is 5.9.1 in the instruction web page.

qutefu gravatar imagequtefu ( 2017-12-06 21:09:02 +0000 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-12-06 23:16:45 +0000

qutefu gravatar image

I found the answer by myself,

"https://social.msdn.microsoft.com/For..."

The SDK is not installed, which is different pacakge, I just think it should be included when I installed the IDE.

edit flag offensive delete link more

Comments

I just think it should be included when I installed the IDE

Then complain about it to Microsoft; we aren't responsible for the packaging of Visual Studio.

Guy Harris gravatar imageGuy Harris ( 2017-12-07 06:18:02 +0000 )edit

Honestly, in the instruction web page the command : choco install VisualStudio2015Community --timeout 0 -package-parameters "--AdminFile path\to\msvc2015AdminDeployment.xml" Can't get the installation of VC++ automatically, I run the cammand for many times, is there any way what we can fix by modify the XML file.

qutefu gravatar imagequtefu ( 2017-12-07 17:50:40 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-06 19:30:49 +0000

Seen: 39 times

Last updated: Dec 07