Ask Your Question
0

How to disable automatic loading of extcap plugins?

asked 2019-01-10 02:43:02 +0000

edward gravatar image

updated 2019-01-11 18:44:27 +0000

Guy Harris gravatar image

I found that wireshark loaded very slow due to plugins loading. How to disable plugins load automatically´╝č I want load the plugins manually when I need.

edit retag flag offensive close merge delete

Comments

We don't generally close questions when they are answered. Instead, please accept the answer (even if it's your own answer) by clicking the checkmark icon next to the answer.

grahamb gravatar imagegrahamb ( 2019-01-10 09:53:16 +0000 )edit

never see any checkmark icon, how to do that?

edward gravatar imageedward ( 2019-01-11 01:28:03 +0000 )edit

As the "answer" has now been moved to a comment, there is no checkmark for "accepting" it. I'll try to clean it up.

grahamb gravatar imagegrahamb ( 2019-01-11 10:18:20 +0000 )edit

As I noted in a comment on the answer, the plugins that are probably causing the slowness are "extcap" plugins rather than "loaded" plugins. You can disable them by renaming the "extcap" directory, so that Wireshark doesn't find any extcap plugins.

Guy Harris gravatar imageGuy Harris ( 2019-01-11 18:45:53 +0000 )edit

1 Answer

Sort by ┬╗ oldest newest most voted
0

answered 2019-01-10 03:36:41 +0000

edward gravatar image

From the help->about->plugins I found the plugins folder 'extcap' and rename it. Then open wireshark again, it opened quickly and no plugins loaded. Or you can move the plugins which is in 'extcap' to other folders, you can move the plugins to 'extcap' again when you need.

edit flag offensive delete link more

Comments

Note that there are two types of plugins:

  1. "Loaded" plugins, which are either compiled code that's loaded into the Wireshark executable (DLL/.so/.dylib/etc.) or Lua code;
  2. Extcap plugins, which are separate programs run by Wireshark.

Renaming the extcap folder prevents the extcap plugins from being run, but doesn't prevent the "loaded" plugins from being loaded.

Extcap plugins do slow down the startup process more than do "loaded" plugins; it appears that disabling extcap plugins sped up your startup, and it may be that the original poster's problem was with the extcap plugins, not the "loaded" plugins.

Guy Harris gravatar imageGuy Harris ( 2019-01-10 04:56:03 +0000 )edit

Ok, thanks.

edward gravatar imageedward ( 2019-01-10 06:12:21 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-10 02:43:02 +0000

Seen: 48 times

Last updated: Jan 11