Ask Your Question
0

plugin entry missing

asked 2018-04-12 14:26:04 +0000

tof gravatar image

updated 2018-04-12 14:28:00 +0000

Hi,

Since my basic dissector POC is now running with LUA, I was trying to start the C version of that based on an empty plugin development as described in the doc.

I set up the whole environment (win64), brought it to compile, and added an empty nut shell of a plugin as explained in the documentation.

Everything built and then I wanted to run that. I copied that into user's personnal plugin directory of WS, but then I had this error (translated from french the best I could):

Entry point of the proto_register_plugin procedure can not be found in the dynamic Library c:\users\<usr>\AppData\Roaming\plugins\foo.dll

So I thought this was a problem with my settings/implementation. But then I remembered that in the documentation, I had to rely on the gryphon plugin as sample. So I copied the gryphon.dll in that same directory, and I got the same problem with the gryphon plugin.

What can be wrong? Have the entry point changed? How can I remedy?

Thanks!

edit retag flag offensive close merge delete

Comments

Please add Wireshark version information. The one you build, the one your run, Compiler environment, etc, etc.

Jaap gravatar imageJaap ( 2018-04-12 14:50:10 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-12 14:58:14 +0000

tof gravatar image

updated 2018-04-12 15:00:08 +0000

Thanks @Jaan, I was just gathering that information when I understood: I was compiling a plugin based on v2.9.0rc0-94-gf0285151 but was running the stable 2.4.6.x version. I guess the entry points have changed in between. Sorry for that

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-12 14:26:04 +0000

Seen: 18 times

Last updated: Apr 12