Ask Your Question
0

CMake Error: CMake can not determine linker language for target:

asked 2018-01-25 20:53:56 +0000

anonymous user

Anonymous

updated 2018-01-25 22:37:37 +0000

Guy Harris gravatar image

Hi,

I am trying to create wireshark dissector plugin. I have referred README.plugins file. I have to create plugin using custom extension. I followed all the steps mentioned in README.plugins upto 3.1. But i am getting error as follows,

-- Configuring done
CMake Error at cmake/modules/WiresharkPlugin.cmake:32 (add_library):
  Cannot find source file:

    packet-75f_wirless.C

  Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
  .hxx .in .txx
Call Stack (most recent call first):
  plugins/75f_wireless/CMakeLists.txt:55 (add_plugin_library)

CMake Error: CMake can not determine linker language for target: 75f_wirless
-- Generating done
-- Build files have been written to: C:/Development/wireshark

So let me know how can remove this linker error.

Thanks, Nilesh

edit retag flag offensive close merge delete

Comments

So what is the name of your source code file?

Guy Harris gravatar imageGuy Harris ( 2018-01-25 22:38:25 +0000 )edit

Source code file: - packet-75f_wireless.C plugin folder name: - 75f_wireless

nileshbhadule gravatar imagenileshbhadule ( 2018-01-26 04:54:26 +0000 )edit

Which version of Wireshark are you attempting to build with?

grahamb gravatar imagegrahamb ( 2018-01-26 10:32:29 +0000 )edit

Its 2.4.2.

nileshbhadule gravatar imagenileshbhadule ( 2018-01-26 13:13:29 +0000 )edit

Is the capital C causing grief?

Anders gravatar imageAnders ( 2018-01-26 13:47:21 +0000 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-01-26 13:28:47 +0000

grahamb gravatar image

Note the spelling of the filename in error message, assuming it was correctly transcribed:

Cannot find source file:
    packet-75f_wirless.C

Do you have a typo in the plugin CMakeLists.txt, misspelling the source file name?

edit flag offensive delete link more

Comments

It was incorrect spelling. So it got resolved.

Thank you very much.

Thanks, Nilesh.

nileshbhadule gravatar imagenileshbhadule ( 2018-01-26 16:56:34 +0000 )edit

I've fixed up the comments and converted it to an answer with your response. Please accept the answer to let others know what the problem was by clicking the checkmark next to the answer.

grahamb gravatar imagegrahamb ( 2018-01-26 17:43:02 +0000 )edit
0

answered 2018-01-26 12:20:12 +0000

Jaap gravatar image

Use the statement add_plugin_library(75f_wireless) or add_plugin_library(75f_wireless epan) for Wireshark 2.4 and Wireshark developmen version respecitvely.

edit flag offensive delete link more

Comments

Are we missing a docs update for the recent changes?

grahamb gravatar imagegrahamb ( 2018-01-26 12:33:22 +0000 )edit

add_plugin_library call is already there in CMakeList.txt in plugin/75f_wireless folder. I have followed gryphon example as mentioned in README.plugins. Thanks, Nilesh

nileshbhadule gravatar imagenileshbhadule ( 2018-01-26 13:15:42 +0000 )edit

@grahamb: I hope not, I've worked on README.plugins in master quite a bit.

@nileshbhadule: Sounds oke. Could you post (on pastebin or something) a directory listing of your plugin directoryand the contents of your plugins CMakeLists.txt file.?

Jaap gravatar imageJaap ( 2018-01-26 15:23:27 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-25 20:53:56 +0000

Seen: 923 times

Last updated: Jan 26