Ask Your Question

SCTP SACK RTT not displayed in version 3.6.6

asked 2022-07-19 10:24:59 +0000

tonyqu gravatar image

Hi, Expert

I'm using latest version of 3.6.6. I found that SCTP SACK RTT not display in package details. And sctp.sack_rtt filter doesn't work either.

But it works well with version 3.4.6. Is there any configuration need to be enabled? I can't upload the pictures. Hope my question is clear. Thanks in advance.

Br, Tony

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-07-19 12:27:58 +0000

Jaap gravatar image

You would need to have the 'Enable TSN Analysis' preference checked.

edit flag offensive delete link more


Hi, Jaap

Great thanks for your answer. I did enable this preference with 3.6.6. It doesn't help. When I filtered with "sctp.sack_rtt > 0", nothing displayed.

Br, Tony

tonyqu gravatar imagetonyqu ( 2022-07-20 01:19:51 +0000 )edit

I've tried loading a sample capture file in both 3.6.6 and the development version. Both showed the presence of this field, for the same packets in that capture file. So from that I can only assume your capture file doesn't contain the necessary packets to have these fields.

Jaap gravatar imageJaap ( 2022-07-20 07:35:50 +0000 )edit

Thanks, Jaap.

I disabled SCTP preference "Relative TSNs", then I got sack_rtt works. Is that reasonable?

Br, Tony

tonyqu gravatar imagetonyqu ( 2022-07-20 07:46:54 +0000 )edit

Yes, then it definitely depends on the type of SCTP packets you have. Not sure if / why the use of relative TSNs is of influence, or that it should, but currently that seems to be the case.

Jaap gravatar imageJaap ( 2022-07-20 10:14:55 +0000 )edit

Thanks again for your help.

tonyqu gravatar imagetonyqu ( 2022-07-20 11:30:43 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2022-07-19 10:24:59 +0000

Seen: 263 times

Last updated: Jul 19 '22