Ask Your Question
0

can not decrypt zigbee packets using TI Smart Sniffer Agent 2

asked 2022-02-01 16:18:16 +0000

dani gravatar image

updated 2022-02-01 17:04:28 +0000

grahamb gravatar image

Hello, I have installed some versions of Wireshark as 3.0.14 or 3.0.6. I also have both plugins copied to the plugins directory. I added the key in the preconfigured file. And I am unable to watch the packets, it says they are malformed or they can not be decrypted.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-02-01 16:32:48 +0000

grahamb gravatar image

Those versions are quite old, the current stable release (3.6.1) should be able to decrypt without plugins, can you try that?

edit flag offensive delete link more

Comments

I am using a Texas Instruments launchpad and they told me that I had to use Smart Sniffer Agent 2 with Wireshark and it had to be version 3.0.X. I think with a newer version it does not work. I can try it again.

Thank you

dani gravatar imagedani ( 2022-02-01 16:37:35 +0000 )edit
Chuckc gravatar imageChuckc ( 2022-02-01 16:47:53 +0000 )edit

You might request that TI update the plugin to the current release rather than something that's been EOL for 15 months (3.0.x), or contribute it to the Wireshark project where it can be properly maintained.

grahamb gravatar imagegrahamb ( 2022-02-01 17:02:50 +0000 )edit

I'll have to look back through my emails. Most of the people involved have moved on and don't think I got an official TI response if they would update it.
This was the last email in the thread from one TI person to another:
"Due to the EOL of Wireshark 3.0.x, what is the plan with our Wireshark dissectors going forward?"

Chuckc gravatar imageChuckc ( 2022-02-01 17:11:18 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2022-02-01 16:18:16 +0000

Seen: 45 times

Last updated: Feb 01