Ask Your Question

Revision history [back]

How to capture HTTPS traffic with v3.0.2?

Hello, I'm trying to figure out how to capture Chrome HTTPS traffic at Windows 7 with Wireshark and have already read tons of manuals and guides. But still, my Wireshark v.3.0.2 does not decrypt TLSv1.2 traffic. Here is what I do: - set environmental variable SSLKEYLOGFILE - start Chrome with --ssl-key-log-file="...path..." key - in Wireshark, set Edit -> Preferences -> Protocols -> TLS -> "(Pre)-Master-Secret log filename" to the same as in both lines above - starting capture

Yet, still no decrypted data being showed at capture log. I'm still getting that "Encrypted Application Data" and no additional tabs showing below. There is no "SSL" protocol in Preferences as well, but most guides references to it so I'm being confused a lot if I doing something wrong. Still, can't get any clue not in google, not here.

Checked it at various sites, even at httpbin.org, was trying to start capture first, browser first, rebooting, etc - still the same result, no HTTPS traffic decryption.

Chrome make it's secret log file perfectly and seem to be writing it correctly.

How to capture HTTPS traffic with v3.0.2?

Hello, I'm trying to figure out how to capture Chrome HTTPS traffic at Windows 7 with Wireshark and have already read tons of manuals and guides. But still, my Wireshark v.3.0.2 does not decrypt TLSv1.2 traffic. Here is what I do: - do:

  • set environmental variable SSLKEYLOGFILE - SSLKEYLOGFILE

  • start Chrome with --ssl-key-log-file="...path..." key - key

  • in Wireshark, set Edit -> Preferences -> Protocols -> TLS -> "(Pre)-Master-Secret log filename" to the same as in both lines above - above

  • starting capture

Yet, still no decrypted data being showed at capture log. I'm still getting that "Encrypted Application Data" and no additional tabs showing below. There is no "SSL" protocol in Preferences as well, but most guides references to it so I'm being confused a lot if I doing something wrong. Still, can't get any clue not in google, not here.

Checked it at various sites, even at httpbin.org, was trying to start capture first, browser first, rebooting, etc - still the same result, no HTTPS traffic decryption.

Chrome make it's secret log file perfectly and seem to be writing it correctly.

How to capture HTTPS traffic with v3.0.2?

Hello, I'm trying to figure out how to capture Chrome HTTPS traffic at Windows 7 with Wireshark and have already read tons of manuals and guides. But still, my Wireshark v.3.0.2 does not decrypt TLSv1.2 traffic. Here is what I do:

  • set environmental variable SSLKEYLOGFILE

  • start Chrome with --ssl-key-log-file="...path..." key

  • in Wireshark, set Edit -> Preferences -> Protocols -> TLS -> "(Pre)-Master-Secret log filename" to the same as in both lines above

  • starting capture

Yet, still no decrypted data being showed at capture log. I'm still getting that "Encrypted Application Data" and no additional tabs showing below. There is no "SSL" protocol in Preferences as well, but most guides references to it so I'm being confused a lot if I doing something wrong. Still, can't get any clue not in google, not nor here.

Checked it at various sites, even at httpbin.org, was trying to start capture first, browser first, rebooting, etc - still the same result, no HTTPS traffic decryption.

Chrome make it's secret log file perfectly and seem to be writing it correctly.

How to capture HTTPS traffic with v3.0.2?

Hello, I'm trying to figure out how to capture Chrome HTTPS traffic at Windows 7 with Wireshark and have already read tons of manuals and guides. But still, my Wireshark v.3.0.2 does not decrypt TLSv1.2 traffic. Here is what I do:

  • set environmental variable SSLKEYLOGFILE

  • start Chrome with --ssl-key-log-file="...path..." key

  • in Wireshark, set Edit -> Preferences -> Protocols -> TLS -> "(Pre)-Master-Secret log filename" to the same as in both lines above

  • starting capture

According to most guides, this should be enough. Yet, still no decrypted data being showed at capture log. I'm still getting that "Encrypted Application Data" and no additional tabs showing below. There is no "SSL" protocol in Preferences as well, but most guides references to it so I'm being confused a lot if I doing something wrong. Still, can't get any clue not in google, nor here.

Checked it at various sites, even at httpbin.org, was trying to start capture first, browser first, rebooting, etc - still the same result, no HTTPS traffic decryption.

Chrome make it's secret log file perfectly and seem to be writing it correctly.

How to capture HTTPS traffic with v3.0.2?

Hello, I'm trying to figure out how to capture Chrome HTTPS traffic at Windows 7 with Wireshark and have already read tons of manuals and guides. But still, my Wireshark v.3.0.2 does not decrypt TLSv1.2 traffic. Here is what I do:

  • set environmental variable SSLKEYLOGFILE

  • start Chrome with --ssl-key-log-file="...path..." key

  • in Wireshark, set Edit -> Preferences -> Protocols -> TLS -> "(Pre)-Master-Secret log filename" to the same as in both lines above

  • starting capture

According to most guides, this should be enough. enough.

Yet, still no decrypted data being showed at capture log. I'm still getting that "Encrypted Application Data" and no additional tabs showing below. There is no "SSL" protocol in Preferences as well, but most guides references to it so I'm being confused a lot if I doing something wrong. Still, can't get any clue not in google, nor here.

Checked it at various sites, even at httpbin.org, was trying to start capture first, browser first, rebooting, etc - still the same result, no HTTPS traffic decryption.

Chrome make it's secret log file perfectly and seem to be writing it correctly.