Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Target Machine keeps losing connectivity when running a arpspoof/ettercat against it

First and foremost, I am new to all of this so any support or help would be appreciated! I know this isnt a direct question related to WS, but it's a result of an original question regarding switched networks.

I have a target machine, (friend's iphone 8, approved for testing purposes) -

My Oracle VM Kali Linux Machine (configured for bridged adapter (eth0))

I know my gateway address

Whenever I try an arp poison, when i try to log into the web application on the iphone, it gets stuck at the loading screen, doesn't progress, and then ultimately drops connectivity. I use the following code on 3 different terminals, in the following order:

echo > 1 /procs/sys/net/ipv4/ip_forward

arpspoof -i eth0 -t -r

arpspoof -i eth0 -t -r

Additionally, I've tried playing around with ettercap, the same result happens. When i try to log into the web application on the iphone, it gets stuck at the loading screen and the ultimately drops connectivity.

Been looking all over for an answer but can't really find anything that's been concrete and helped. Couple additional notes to add, whether useful or not: 1)the website is a non-secure HTTP site so i dont think any SSL stripping would need to happen; 2) when i ping the site, i get no reply...Which leads me to think there could be a firewall of some sort? 3) i know the traffic is clear text and can obtain credentials using wireshark as i've done it on my own computer before. Now that ive learned I have a switched network, i've come across the problem i presented.

Any point of direction or help would be extremely appreciated!

Thank you.