Hello,

I use centos 5.7, I wish to install the wireshark source code. When I set up the lastest version with a checkout of http: // anonsvn.wireshark.org / wireshark / trunk, he asks me to install some packages which exists only in higher versions then 5.7. Do you know what wireshark version i have to install (http: // anonsvn.wireshark.org /)? Thank you

asked 14 Dec '12, 07:03

Gigi's gravatar image

Gigi
6336
accept rate: 100%

what are those dependencies/packages?

(14 Dec '12, 10:38) Kurt Knochner ♦

I know that Wireshark 1.8.x won't compile on CentOS 5.

I think that Wireshark 1.6.x will though I haven't tried recently (oh, wait, a quick check shows that CentOS 5 comes with autoconf 2.59 and Wireshark 1.6.x requires 2.60 so to do Wireshark 1.6 you'd need to at least upgrade autoconf).

link

answered 14 Dec '12, 10:49

JeffMorriss's gravatar image

JeffMorriss ♦
3.8k555
accept rate: 23%

Thank you, i try to install autoconf 2.6 to use wireshark 1.6 but i have a lot of not resolved dependencies and i don't find the rpm of libdb.so.2. Do you khnow how i have to install it pr upgrade autoconf.

Thank you

(18 Dec '12, 12:32) Gigi

Well, compiling Wireshark does require a fair number of development packages; these should be detailed in the INSTALL file. I've been working on a CentOS 5 build from an RPM and this is what I have as requirements to build:

BuildRequires: libpcap-devel >= 0.9 BuildRequires: zlib-devel BuildRequires: glib2-devel BuildRequires: gtk2-devel >= 2.4 BuildRequires: autoconf BuildRequires: python BuildRequires: gnutls-devel BuildRequires: desktop-file-utils BuildRequires: flex, bison

(19 Dec '12, 06:54) JeffMorriss ♦

(Ran out of room in that comment, here's the rest...)

I don't know what is libdb.so.2 or why you'd need it. I just successfully compiled 1.6.12 on CentOS 5 last night. My system does have libdb.so (from the db4-devel package) but my Wireshark doesn't use it.

(19 Dec '12, 06:55) JeffMorriss ♦

Thank you but when i try to install the RPM of autoconf that's not work. So i install it from the code source (make install) and that work well.

(19 Dec '12, 10:40) Gigi

Can anyone confirm that this method works because,I too want to install wireshark 1.6 to centos 5.7 but now it requires glibc version higher than 2.4. But CentOs 5.7 only supports version 1.2

(19 Jan, 04:49) Badhi

Wireshark does not generally require a particular glibc version. Do you mean a glib version higher than 2.4? In that case try installing the glib2 RPM ("yum install glib2 glib2-devel" as root). (glib version 1 has the package name "glib" but version 2's packages are named "glib2".)

Anyway, yes, I've been building Wireshark 1.6 on RHEL/CentOS 5 for years. But, as I mentioned you do need an upgraded autoconf.

(19 Jan, 07:00) JeffMorriss ♦

Thanks for the reply. Yeah you are correct it is glib. Now I manged to run configure file successfully. But when making an error occurs at priviledges.h saying following,

privileges.c:33:18: error: glib.h: No such file or directory

with that a lot of other errors follows

(20 Jan, 02:41) Badhi

Did you "yum install glib2-devel"? The glib.h file is in the "-devel" package.

(20 Jan, 07:42) JeffMorriss ♦

Yes glib2-devel 2.12.3 is installed. If it helps this is the rest of the errors

privileges.c:33:18: error: glib.h: No such file or directory In file included from privileges.c:35: privileges.h:44: error: expected '=', ',', ';', 'asm' or 'attribute' before 'started_with_special_privs' privileges.h:52: error: expected '=', ',', ';', 'asm' or 'attribute' before 'running_with_special_privs' privileges.h:65: error: expected '=', ',', ';', 'asm' or 'attribute' before '' token privileges.h:72: error: expected '=', ',', ';', 'asm' or 'attribute' before '' token privileges.c:182: error: expected '=', ',', ';', 'asm' or 'attribute' before 'init_process_policies_called' privileges.c: In function 'init_process_policies': privileges.c:203: error: 'init_process_policies_called' undeclared (first use in this function) privileges.c:203: error: (Each undeclared identifier is reported only once privileges.c:203: error: for each function it appears in.) privileges.c:203: error: 'TRUE' undeclared (first use in this function) privileges.c: At top level: privileges.c:211: error: expected '=', ',', ';', 'asm' or 'attribute' before 'started_with_special_privs' privileges.c:226: error: expected '=', ',', ';', 'asm' or 'attribute' before 'running_with_special_privs' privileges.c:293: error: expected '=', ',', ';', 'asm' or 'attribute' before '' token privileges.c:310: error: expected '=', ',', ';', 'asm' or 'attribute' before '' token

(20 Jan, 09:12) Badhi

I was able to locate glib.h in two locations - /usr/include/glib-2.0 and /usr/include/glib-1.2. Isn't this the required file?

(20 Jan, 20:59) Badhi

Ok I was able to resolve the above error. It occurred because of the .h files were in the wrong locations. But now I get error similar to ascendtext.c:331: error: expected ';', ',' or ')' before '_U_'. Could this be due to the incompatibility of glib version? (since the installed version is glib2-devel 2.12.3 it requires >=2.4)

(20 Jan, 22:25) Badhi

Hmm, actually glib.h should be in /usr/include/glib-2.0. And pkg-config should tell Wireshark to find it there (the output of pkg-config --cflags glib-2.0 should include -I/usr/include/glib-2.0).

I don't have a good idea for what's going wrong on your system. Are you doing in in-source-tree or out-of-source-tree build? (Are you running ./configure or, for example, ../configure)?

(21 Jan, 07:56) JeffMorriss ♦

I don't have a knowledge about in-source-tree or out-of-source tree concepts. But I use ./configure

(23 Jan, 21:39) Badhi
showing 5 of 13 show 8 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: 14 Dec '12, 07:03

Seen: 1,861 times

Last updated: 23 Jan, 21:39

Related questions

p​o​w​e​r​e​d by O​S​Q​A