Ask Your Question

Revision history [back]

Uninstall/Reinstall 'corrupts' windows 7 network stack


Not really a question more of a warning (and maybe something devs can look into).

A few weeks ago on my work windows 7 PC i ran into So I uninstalled whatever version of wireshark I had, and reinstalled the latest version without usbcap and everything worked fine. I did not do a reboot during the whole process or afterwards, till 2 weeks ago and all of a sudden after rebooting my work pc for another reason I did not have network access anymore. (Which led to me trying all kinds of things including windows repair which completely corrupted the startup process so windows would not even boot anymore and me ordering a new pc since the old one was 10 years old. I did think of wireshark at the time.)

Fast forward to day before yesterday and I am running into the the external capture plugin issue on my windows 7 home PC. No worries I know what to do I and uninstall/reinstall of latest version without usbcap and everything works as expected. I start my home pc yesterday morning and while I still have internet for some reason I cannot connect to the work network anymore using OpenVPN. Checking the routing tables and everything seems fine, but packets are just not following the rules of the routing table (packets that should go the the work range end up on the normal interface ). I spend a few hours trying all kinds of things, uninstalling wireshark and openvpn and the network adapters etc without result. Then i uninstalled everything and followed the steps on, reinstalled openvpn and now it works again.

It could all be a coincidence of course but it get the feeling wireshark uninstall/reinstall is doing something fishy.

Hope it helps someone.