Ask Your Question

Revision history [back]

Upgraded Wireshark, VPN connections stop working

As an infrequent user of Wireshark, when I ran the installed version this afternoon, I was prompted to upgrade to v3.2.2 from 2.4.4 on my Windows 8.1 x64 machine.

The upgrade recommended removing WinPCap (manually) and replaced it with Npcap. After the required reboot, I found that none of my Windows VPN connections worked any longer. When I click on "connect", Taskmgr shows explorer.exe as "not responding" and Device manager lists all the associated Wan Miniport devices with exclamation marks and the status of "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)" until the connection attempt times out at which point Explorer starts responding again and the Miniport devices all go back to hidden.

Uninstalling Npcap(without a reboot) didn't help. Uninstalling Wireshark didn't help either and the only thing that got the functionality back was to do a System Restore to yesterday.

After the System Restore, I checked that all of the VPN connections were working again then tried reinstalling Wireshark. A reboot was required again and after the reboot I got exactly the same result - couldn't connect to any VPNs.

I am about to do the System Restore again but I wondered if anyone has seen this kind of behaviour before and if there anything that can be done?

Thanks in advance

David Stafford