OSQA is unmaintained. Help us figure out where to go from here.
0
1

Hi!

I know this is not specifically Wireshark problem, but people here are more likely done this themselves.

All packets shows DSCP values being 0x00 (default), how can I get DSCP configurations to work in Windows 7 (x64 pro)?

I have configured them like this:

  1. I've been defining QoS policy settings from Group Policy Editor: Computer Configuration -> Windows Settings -> Policy-based QoS (Screenshot)
  2. From "Advanced QoS settings" I have ticked the "Control DSCP marking requests from applications and services" with "Ignored: Only QoS policies can specify DSCP value".
  3. I have QoS Packet Scheduler in Network Card settings turned on.

Stuff I've tried, without help:

Update: I found out that using qostraffic.exe -source -tcp -dest 192.168.1.1,80 -throttle 1000 -tc 40,4 I can mark the packets if I run it as administrator! But all packets Windows creates "normally" are not marked.

Update: This is probably a bug in Windows 7, other people seem to have a same problem in QoS Policy MSDN thread.

asked 01 Dec '10, 03:19

Ciantic's gravatar image

Ciantic
16124
accept rate: 100%

edited 12 Dec '10, 07:40

Have you seen this... http://itexpertvoice.com/home/getting-the-most-out-of-your-windows-7-internet-connection/ It's an interesting article and something to try. Caveat - haven't done myself.

(02 Dec '10, 00:15) lchappell ♦

@lchapell: Thanks, I read it, though did not fix the problem. New thing in the article was the tool qostraffic.exe that creates QoS traffic, and it also unfortunately cannot set the DSCP field in IP header. But should be helpful for debugging further.

(02 Dec '10, 02:23) Ciantic

I found an answer, thanks goes to xedoc in speedguide.net

Use following registry file to circumvent Domain Joined limitation of Win7:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\QoS]
"Do not use NLA"="1"

That is, create REG_SZ "Do not use NLA" and set it to "1" and create key "QoS" if it does not exist.

permanent link

answered 06 Jan '11, 05:40

Ciantic's gravatar image

Ciantic
16124
accept rate: 100%

Is your computer part of a domain?

Check out the Microsoft QoS Blog at http://blogs.msdn.com/b/wndp/archive/2009/01/28/qos-in-windows-7.aspx

The discussion includes a statement from the QoS program manager: "I forgot to point out in my response to Aibulat that a client computer (running Win7 client SKU) has to be domain-joined in order for the local QoS policies to be effective."

permanent link

answered 07 Dec '10, 10:57

packethunter's gravatar image

packethunter
2.1k71547
accept rate: 8%

Very interesting. I tried the "Join a Domain" entry in Start Menu, but all it does it allows me to specify the workgroup again, I did retry specifying it and restarted, did not help. But if that workgroup thing is "joining a domain", I had joined a domain already since I can see other computers in my LAN.

(11 Dec '10, 07:29) Ciantic

Joining a domain requires a workstation with Windows 7 Professional, Ultimate or Enterprise. You need at least one dedicated server configured as domain controller.

(12 Dec '10, 13:09) packethunter
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×102
×23

question asked: 01 Dec '10, 03:19

question was seen: 34,813 times

last updated: 06 Jan '11, 05:40

p​o​w​e​r​e​d by O​S​Q​A