Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Wireshark sees UDP data, application does not

I have a couple devices sending UDP messages to each other. When I connect my PC running Win 10 to their network, I can see the messages via WireShark. When I run a program to parse the messages, it's not seeing the messages. I tried on two different PC's running Win 10 and neither of them see the data.

I've disabled every firewall I can think of. I've given permission to the parsing program to have access through any firewalls. I've created a rule to allow ALL UDP messages through the firewall. I'm not using Norton. I've disabled all other network adapters except the one being used.

I've also tried using a different program. I tried UDP Send/Receive in Receive mode only. It does not see anything.

When I run the parsing program on a PC running Windows XP, it works fine.

What else is there to check in Win 10 that might be preventing applications from getting UDP messages?