Ask Your Question
0

Not able to Capture packets on Remote Interface

asked 2019-03-06 02:32:59 +0000

kruthika gravatar image

updated 2019-03-06 11:27:52 +0000

Guy Harris gravatar image

The capture session could not be initiated on interface 'rpcap://[192.168.1.67]/eth0' (The interface name has not been specified in the source string.).

Above Error is displayed when trying to capture packets on the Polycom phone after adding it as remote Interface.

Wireshark Version:Version 3.0.0, on Windows

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-03-07 00:53:40 +0000

Guy Harris gravatar image

updated 2019-03-07 00:58:34 +0000

Npcap's support for remote capture is broken; Npcap is based on libpcap 1.8.1, and the support for remote capture in libpcap 1.8.1 was very much a work in progress (as in "it didn't even compile on UN*Xes, and had issues on Windows even if you could compile it).

You'll have to use WinPcap, or wait for Npcap to upgrade to libpcap 1.9.0. See nmap issue #1506.

edit flag offensive delete link more

Comments

I was able to figure out that the issue is with the Wireshark Version ,Same Configuration was working fine for remote capture in Wireshark version Version 2.6.5

kruthika gravatar imagekruthika ( 2019-03-07 02:40:25 +0000 )edit

Thank you for the answer.

kruthika gravatar imagekruthika ( 2019-03-07 02:44:59 +0000 )edit

I was able to figure out that the issue is with the Wireshark Version ,Same Configuration was working fine for remote capture in Wireshark version Version 2.6.5

Which probably means that you're now using WinPcap.

Guy Harris gravatar imageGuy Harris ( 2019-03-07 03:17:36 +0000 )edit

Ya this is using WinPcap (4_1_3)

kruthika gravatar imagekruthika ( 2019-03-07 03:31:07 +0000 )edit
0

answered 2019-03-06 13:27:20 +0000

Jaap gravatar image

updated 2019-03-06 13:28:05 +0000

Going from this page you seem to have to set port 2002.

Oh, and you have to have the capture option enabled in the phone configuration.

edit flag offensive delete link more

Comments

Going from this page you seem to have to set port 2002.

That should not have to be necessary, given that port 2002 is the default port for rpcap.

Guy Harris gravatar imageGuy Harris ( 2019-03-06 18:58:11 +0000 )edit

I was able to figure out that the issue is with the Wireshark Version ,Same Configuration was working fine for remote capture in Wireshark version Version 2.6.5

kruthika gravatar imagekruthika ( 2019-03-07 02:40:28 +0000 )edit

I had enabled Capture option on Phone <capture diags.pcap.enabled="1" diags.pcap.remote.enabled="1"/>

kruthika gravatar imagekruthika ( 2019-03-07 02:41:50 +0000 )edit

I was able to figure out that the issue is with the Wireshark Version ,Same Configuration was working fine for remote capture in Wireshark version Version 2.6.5

Probably because it installed WinPcap, so you had a version of pcap that with remote capture support that works with Wireshark.

Guy Harris gravatar imageGuy Harris ( 2019-03-07 03:17:12 +0000 )edit

Since remote Capture was not working with Version 3.0 Wireshark i just downgraded the version and checked the same.

kruthika gravatar imagekruthika ( 2019-03-07 03:32:36 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-06 02:32:59 +0000

Seen: 279 times

Last updated: Mar 07