Ask Your Question
0

problem with npcap installation

asked 2023-07-21 09:30:09 +0000

Sybelian gravatar image

updated 2023-07-21 09:56:35 +0000

I've been looking for a solution to this problem for a few days. I installed wireshark without any problems and it worked perfectly. After that I needed to develop a custom dissector, so I set up the build environment without a problem and after that I realised it was version 4.1, so I checkout into the version 4.07 and built again without a problem. Here's the problem Version 4.1 uses npcap version 1.7.5 wireshark 4.0.7 uses npcap 1.71, so I uninstalled npcap 1.75 to reinstall npcap 1.71. however after reinstalling version 1. 71 and that it appears well in the control panel as soon as I launch wireshark it says to me to type in a terminal as administrator net start npcap what to which it answers me :

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

so I uninstall wirehsark npcap and the remaining files and reinstall and the problem remain i have tried to use winpcap nothing change. Here is my about wireshark

Compiled (64-bit) using Microsoft Visual Studio 2022 (VC++ 14.32, build 31332),
with GLib 2.72.3, with PCRE2, with zlib 1.2.12, with Qt 5.15.2, with libpcap,
with Lua 5.2.4, with GnuTLS 3.6.3 and PKCS #11 support, with Gcrypt 1.10.1, with
Kerberos (MIT), with MaxMind, with nghttp2 1.46.0, with brotli, with LZ4, with
Zstandard, with Snappy, with libxml2 2.9.14, with libsmi 0.4.8, with
QtMultimedia, with automatic updates using WinSparkle 0.8.0, with AirPcap, with
SpeexDSP (using bundled resampler), with Minizip, with binary plugins.

Running on 64-bit Windows 10 (22H2), build 19045, with 11th Gen Intel(R)
Core(TM) i7-1165G7 @ 2.80GHz (with SSE4.2), with 16082 MB of physical memory,
with GLib 2.72.3, with PCRE2 10.40 2022-04-14, with Qt 5.15.2, with Npcap
version 1.71, based on libpcap version 1.10.2-PRE-GIT, with c-ares 1.18.1, with
GnuTLS 3.6.3, with Gcrypt 1.10.1, with nghttp2 1.46.0, with brotli 1.0.9, with
LZ4 1.9.3, with Zstandard 1.5.2, without AirPcap, with light display mode, with
HiDPI, with LC_TYPE=French_France.utf8, binary plugins supported.

if anyone has any idea what the problem is, I'd appreciate it. i have tried this page on the forum about a similar bug without any succes

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-07-21 09:50:20 +0000

grahamb gravatar image

updated 2023-07-21 13:44:10 +0000

Jaap gravatar image

There's no need to revert npcap to 1.71, apart from issues that are fixed in 1.75, there's no functional difference between the two, so use the latest.

The issue appears to be an npcap failure to install correctly. Try manually installing npcap 1.75 again, if that doesn't fix it, then it's a problem for npcap support.

edit flag offensive delete link more

Comments

FYI: Latest version of npcap is now 1.76.

cmaynard gravatar imagecmaynard ( 2023-07-21 14:52:28 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2023-07-21 09:30:09 +0000

Seen: 903 times

Last updated: Jul 21 '23