Ask Your Question
0

Please turn off promiscuous mode for this device

asked 2023-01-01 04:44:58 +0000

wenxu gravatar image

The capture session could not be initiated on capture device "\Device\NPF_{A9DFFDF9-4F57-49B0-B360-B5E6C9B956DF}" (failed to set hardware filter to promiscuous mode: 连到系统上的设备没有发挥作用。 (31)).

I have no problem using this software in win10, but since I upgraded to win11, it cannot be used normally, like this.

How can I solve it?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2023-01-01 08:21:56 +0000

Guy Harris gravatar image

Please turn off promiscuous mode for this device

Sure, tell us where your computer is, and let us select Capture > Options and click the "Promisc" checkbox for that interface; that wil turn off promiscuous mode.

Or you could do that yourself, so that Wireshark doesn't try to turn pomiscuous mode on.

(The problem is probably a combination of 1) that device's driver doesn't support promiscuous mde and 2) a recent change to the Npcap driver caused it so that it no longer attempted to hide the error code that the driver returns from that from some crap code inside Windows that turns the "not supported" error that Npcap will ignore into some generic uninformative error that Npcap has no idea that it should ignore. Thanks, Microsoft!)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2023-01-01 04:44:58 +0000

Seen: 2,402 times

Last updated: Jan 01