Ask Your Question

Upgraded Mac M1 to Ventura 13.1. The upgrade broke Wireshark.

asked 2022-12-13 22:49:51 +0000

mig gravatar image

updated 2022-12-14 09:05:02 +0000

Jaap gravatar image

"You don't have permission to capture on local interfaces. You can fix this by installing ChmodBPF."

Have run ChmodBPF several times and it completes successfully but problem persists.

edit retag flag offensive close merge delete


I am new to this, when i get that error and I go to install ChmodBPF the intaller doesn't work, how do i go about installinh ChmodBPF, sorry for such a newb question

Andythetallguy gravatar imageAndythetallguy ( 2023-02-06 21:26:54 +0000 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2022-12-14 12:15:29 +0000

Dan Mathiasen gravatar image

Bumped into this as well after 13.1. Executing that script from the UI appears not to have the desired effect. You can try running the script from a terminal with sudo:

sudo /Library/Application\ Support/Wireshark/ChmodBPF/ChmodBPF
edit flag offensive delete link more


Worked. Many Thanks.

mig gravatar imagemig ( 2022-12-14 15:22:58 +0000 )edit

Not persistent across reboots. Have to do this each time machine boots.

mig gravatar imagemig ( 2022-12-26 16:52:27 +0000 )edit

I am having the same issues as well.. Hope wireshark devs fix this sooner than later :(

NTEng gravatar imageNTEng ( 2023-01-11 05:23:14 +0000 )edit

answered 2023-02-09 18:23:06 +0000

Gerald Combs gravatar image

This sounds like issue 18734. The current recommended fix is to

  • For now (Feb 2023), download a development release from After March 1, just use 4.0.4 or later.
  • Open and run "Uninstall ChmodBPF"
  • Open and run "Install ChmodBPF"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2022-12-13 22:49:51 +0000

Seen: 4,252 times

Last updated: Feb 09 '23