Ask Your Question
0

Proportional Font in release 4.0.1?

asked 2022-11-16 11:22:34 +0000

drapp gravatar image

Relatively new to wireshark. The prior build I had worked fine, all good in alignments. Just upgraded to 4.0.1 and the view area showing the dump of hex bytes and corresponding ASCII is in a proportional font and all staggered. Anyone else encounter this? I am running same machine as before the update when it looked good, but now nuisance to view. Do I need to downgrade and get an old build instead? Not seeing much in the line of menu access and think this would NOT be something that should have been changed from a fixed-width font.

edit retag flag offensive close merge delete

Comments

What's the "Main window font" specified in Preferences | Appearance | Font and Colors?

grahamb gravatar imagegrahamb ( 2022-11-16 11:30:14 +0000 )edit

Sorry, its not showing ANY "Default" font, nor is it anything I would have changed either. Has header of Fonts, allows to add new fonts and shows all available, but nothing is so designated as a system default font. However, using Powershell, it is showing as Arial. Is that the basis of those window areas? So I would need to change it? But never changed to begin with either.

drapp gravatar imagedrapp ( 2022-11-16 12:28:33 +0000 )edit

Thanks. Went into registry editor and changed to Courier New, all is good... To ME, an editor window such as that should always be FORCED to use a known/common fixed-type font to supersede what Windows default is. Guess it would look funny and in trouble if someone changed default font to a WingDings though :)

drapp gravatar imagedrapp ( 2022-11-16 12:36:06 +0000 )edit

I have no idea what you are doing with PowerShell or regedit, but the "correct" way to modify the font in Wireshark is via the path I noted above: Preferences | Appearance | Font and Colors

grahamb gravatar imagegrahamb ( 2022-11-16 13:43:30 +0000 )edit

An image indicating the font setting.

image description

grahamb gravatar imagegrahamb ( 2022-11-16 13:45:07 +0000 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2022-11-16 17:22:28 +0000

André gravatar image

This is a known issue https://gitlab.com/wireshark/wireshar... and only occurs if version 4.0.0 was a clean install and upgraded to 4.0.1 because of the downgrade from Qt6 to Qt5 on Windows.

The workaround is simple: just change(!) the font or font-size in the preferences under Preferences | Appearance | Font and Colors. This will update the preferences file with a font setting (gui.qt.font_name) that is recognized by Qt5.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-11-16 11:22:34 +0000

Seen: 422 times

Last updated: Nov 16