Ask Your Question
0

Unable to generate Xcode project file

asked 2022-10-31 22:02:20 +0000

Anawat gravatar image

updated 2022-11-01 08:15:24 +0000

Guy Harris gravatar image

I was able to compile wireshark 4.0.1 on Mac M1 running Mac OS 12.6.

Then I tried to run cmake to generate Xcode project file and it failed with this error message.


cmake -G Xcode ../
-- Generating build using CMake 3.21.4
-- Using "Xcode" generator (multi-config)
-- LTO/IPO is not enabled
-- V: 4.0.1, MaV: 4, MiV: 0, PL: 1, EV: .
-- Linker flags: 
-- Could NOT find LIBSSH (missing: LIBSSH_LIBRARIES LIBSSH_INCLUDE_DIRS LIBSSH_VERSION) (Required is at least version "0.6")
-- Checking for one of the modules 'libpcap'
-- Could NOT find Sparkle: Found unsuitable version "1", but required is at least "2" (found SPARKLE_INCLUDE_DIR-NOTFOUND)
-- Could NOT find MaxMindDB (missing: MAXMINDDB_LIBRARY MAXMINDDB_INCLUDE_DIR) 
-- Could NOT find SMI (missing: SMI_LIBRARY SMI_INCLUDE_DIR) 
-- Checking for one of the modules 'krb5;mit-krb5;heimdal-krb5'
-- Could NOT find Minizip (missing: MINIZIP_LIBRARY MINIZIP_INCLUDE_DIR) (found version "")
-- Could NOT find BROTLI (missing: BROTLIDEC_LIBRARY BROTLI_INCLUDE_DIR) 
-- Checking for one of the modules 'lz4;liblz4'
-- Could NOT find LZ4 (missing: LZ4_LIBRARY LZ4_INCLUDE_DIR) 
-- Could NOT find SNAPPY (missing: SNAPPY_LIBRARY SNAPPY_INCLUDE_DIR) 
-- Checking for one of the modules 'libzstd'
-- Could NOT find ZSTD: Found unsuitable version "", but required is at least "1.0.0" (found ZSTD_LIBRARY-NOTFOUND)
-- Checking for one of the modules 'lua5.2;lua-5.2;lua52;lua5.1;lua-5.1;lua51'
-- Checking for one of the modules 'lua<=5.2.99'
-- Could NOT find LUA (missing: LUA_VERSION_NUM) (Required is at least version "5.1")
-- Could NOT find SBC (missing: SBC_LIBRARY SBC_INCLUDE_DIR) 
-- Checking for one of the modules 'spandsp'
-- Could NOT find SPANDSP (missing: SPANDSP_LIBRARY SPANDSP_INCLUDE_DIR) 
-- Could NOT find BCG729 (missing: BCG729_LIBRARY BCG729_INCLUDE_DIR) 
-- Checking for one of the modules 'libilbc'
-- Could NOT find ILBC (missing: ILBC_LIBRARY ILBC_INCLUDE_DIR) 
-- Checking for one of the modules 'opus'
-- Could NOT find OPUS (missing: OPUS_LIBRARY OPUS_INCLUDE_DIR) 
-- Could NOT find DOXYGEN (missing: DOXYGEN_EXECUTABLE) 
-- Could NOT find SpeexDSP (missing: SPEEXDSP_LIBRARY SPEEXDSP_INCLUDE_DIR) (found version "")
-- Building for Mac OS X/OS X/macOS 10.13 using SDK /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX12.3.sdk
-- SSE4.2 compiler flag: -msse4.2
-- C-Flags: -fvisibility=hidden  -Qunused-arguments -Wall -Wextra -Wendif-labels -Wpointer-arith -Wformat-security -fwrapv -fno-strict-overflow -Wvla -Waddress -Wattributes -Wdiv-by-zero -Wignored-qualifiers -Wpragmas -Wno-overlength-strings -Wno-long-long -Wheader-guard -Wcomma -Wshorten-64-to-32 -Wredundant-decls -Wframe-larger-than=32768 -Wunused-const-variable -Wshadow -Wold-style-definition -Wstrict-prototypes -Werror=implicit -Wno-pointer-sign  -fmacro-prefix-map=/Users/AnawatChankhunthod/Lucid/LucidDepot/wireshark/= -fmacro-prefix-map=/Users/AnawatChankhunthod/Lucid/LucidDepot/wireshark/XBuild/= -fmacro-prefix-map=../= 
-- CXX-Flags:  -Qunused-arguments -Wall -Wextra -Wendif-labels -Wpointer-arith -Wformat-security -fwrapv -fno-strict-overflow -Wvla -Waddress -Wattributes -Wdiv-by-zero -Wignored-qualifiers -Wpragmas -Wno-overlength-strings -Wno-long-long -Wheader-guard -Wcomma -Wshorten-64-to-32 -Wredundant-decls -Wframe-larger-than=32768 -Wextra-semi  -fmacro-prefix-map=/Users/AnawatChankhunthod/Lucid/LucidDepot/wireshark/= -fmacro-prefix-map=/Users/AnawatChankhunthod/Lucid/LucidDepot/wireshark/XBuild/= -fmacro-prefix-map=../= 
-- Warnings as errors disabled
-- The following OPTIONAL packages have been found:

 * Git
 * GMODULE2
 * Perl
 * Gettext
 * PCAP
 * Qt5Network (required version >= 5.15.6)
 * Qt5Multimedia
 * GNUTLS (required version >= 3.5.8)
 * KERBEROS
 * ZLIB
 * NGHTTP2 (required version >= 1.11.0), HTTP/2 C library and tools, <https: nghttp2.org="">
   Header decompression in HTTP2
 * LibXml2
 * Asciidoctor (required version >= 1.5)
 * XSLTPROC

-- The following REQUIRED packages have been found:

 * GLIB2 (required version >= 2.50.0)
 * GTHREAD2
 * GCRYPT (required version >= 1.8.0)
 * CARES ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2022-11-01 08:51:58 +0000

Guy Harris gravatar image

For some unknown reason, the doc directory's CMakeLists.txt file has two targets, "docs" and "manpages", and all the man pages are in both of those targets. For some other unknown reason, "the Xcode "new build system"" can't handle that, even though Make and Ninja and Visual Studio appear to have No Problem with it.

It is not clear why this is done.

Please file an issue for this problem on the Wireshark issues list, to make a record of this.

edit flag offensive delete link more

Comments

Anawat gravatar imageAnawat ( 2022-11-03 00:04:51 +0000 )edit
0

answered 2022-11-01 03:09:16 +0000

Chuckc gravatar image

updated 2022-11-01 03:10:50 +0000

(Not a Mac guy. Maybe one will wander by and confirm this or offer a better solution.)
An example where this was solved: "is attached to multiple targets"

Solution explained here (CMAKE_XCODE_BUILD_SYSTEM):

1 The original Xcode build system. This is the default when using Xcode 11.x or below.

and here (Toolset and Build System Selection):

For example, to select the original build system under Xcode 12, run cmake(1) with the option -T buildsystem=1.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-10-31 22:02:20 +0000

Seen: 86 times

Last updated: Nov 01 '22