Ask Your Question
0

how to build specific protocol version dissector

asked 2022-08-10 14:14:45 +0000

ayoubtellaa gravatar image

updated 2022-08-10 14:37:21 +0000

Hello I am trying to build a specific version for f1ap protocol (F1AP version 15.2.1), but till today, I still can't do it , I tried to copy the file from Wireshark version (2.9.0 ) that uses the protocol version to the one i am using (3.6.4), and to build it but no luck can someone help, please

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-08-10 14:43:45 +0000

grahamb gravatar image

You aren't giving any clues as to why you you think you need to copy the dissector from 2.9.0 to 3.6.4 or can't build the dissector so it's very difficult to help.

As there's a large jump in versions between 2.9.0 and 3.6.4 so it's likely that there have been fundamental changes within Wireshark that cause a simple copy of the dissector to no longer compile. The dissector will have to be modified to confirm with the target version of Wireshark.

As an fiap dissector was added to Wireshark in 2.6.0, it's likely you have a custom modified version of the dissector, so you task is to work out what those custom modifications where, and then apply them to the appropriate source file for your target version (3.6.4). Hopefully you have history in version control somewhere to easily see what those changes were.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-08-10 14:14:45 +0000

Seen: 33 times

Last updated: Aug 10