Ask Your Question
0

capture interface not displayed

asked 2021-04-09 14:10:37 +0000

user83 gravatar image

Hi, on my linux system (3.8.13-16.2.1.el6uek.x86_64) i used a command to attach another IP to an existing interface (eth1)

ifconfig eth1:0 172.16.67.254 netmask 255.255.0.0

I see the interface via (ifconfig ) and I can ping other devices on the network using ping -I eth1:0. My issue is when i try and capture frames from the device I don't see the interface displayed in wireshark. I do see Eth1 and i can capture frames on that interface.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-04-09 14:29:00 +0000

grahamb gravatar image

You haven't created an additional interface, you've just added an IP, so the interfaces list in Wireshark will still show the single interface.

If you hover over the interface in the list you should see all associated IP addresses for that interface.

edit flag offensive delete link more

Comments

@grahamb, Thanks for the quick reply. I do see the additional IP in the list. I guess i expected to see eth1:0, but as you pointed out it's not another interface. I'll just use a filter to capture that IP traffic

user83 gravatar imageuser83 ( 2021-04-09 15:11:05 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-04-09 14:10:37 +0000

Seen: 140 times

Last updated: Apr 09