Ask Your Question
0

interfaces missing in 2.6.4 on CentOS7

asked 2018-10-13 14:38:34 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I installed ver 2.6.4 on CentOS7. No ethernet interfaces are available for capture in Wireshark. I have: added the user to the wireshark users group

The logged in user is an administrator The Ethernet (Wired) connection is active.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-10-16 21:01:52 +0000

Somewhere I saw that this issue can be an indication that Wireshark did not install completely or correctly. So based on that info I reinstalled using the source file, extracted and compiled.

$ wget https://1.as.dl.wireshark.org/src/wir...

$ tar -xf wireshark-2.6.4.tar.xz -C /tmp

$ cd /tmp/wireshark-2.6.4

$ ./autogen.sh

$ ./configure –enable-setcap-install

$ make

$ sudo make install

$ sudo ldconfig

Thanks to https://linuxtechlab.com/install-wire... for the solution.

edit flag offensive delete link more
0

answered 2018-10-13 18:41:12 +0000

Jaap gravatar image

Did you logout and login again?

edit flag offensive delete link more

Comments

Yes, sorry I forgot to list that step

lloving gravatar imagelloving ( 2018-10-13 20:50:02 +0000 )edit

(Since it appears to have answered your question I converted @Jaap's comment to an answer.)

JeffMorriss gravatar imageJeffMorriss ( 2018-10-15 13:04:40 +0000 )edit

I did logout and logged in again but that did not solve the problem, still no Ethernet interfaces shown. There is a Random Packet Generator and a UDP Listener remote capture but nothing else.

lloving gravatar imagelloving ( 2018-10-16 01:43:32 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-13 14:38:34 +0000

Seen: 79 times

Last updated: Oct 16