Ask Your Question
0

Windows 10 - no interfaces found

asked 2021-04-08 05:58:25 +0000

yulim gravatar image

updated 2021-04-08 09:24:41 +0000

grahamb gravatar image

I opened the wireshark then no interfaces found. I click about wireshark but there is no dialog. there are wireshark, authors, folders, plugins, keyboard shortcuts, acknowledgments, and license tab.

edit retag flag offensive close merge delete

Comments

About details:

Version 3.0.3 (v3.0.3-0-g6130b92b0ec6) 

Copyright 1998-2019 Gerald Combs <[email protected]> and contributors. License GPLv2+: GNU GPL version 2 or later <http://www.gnu.org/licenses/old-licenses/gpl-2.0.html> This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

Compiled (64-bit) with Qt 5.12.4, with WinPcap SDK (WpdPack) 4.1.2, with GLib 2.52.2, with zlib 1.2.11, with SMI 0.4.8, with c-ares 1.14.0, with Lua 5.2.4, with GnuTLS 3.6.3 and PKCS #11 support, with Gcrypt 1.8.3, with MIT Kerberos, with MaxMind DB resolver, with nghttp2 1.14.0, with LZ4, with Snappy, with libxml2 2.9.9, with QtMultimedia, with AirPcap, with SBC, with SpanDSP, with bcg729. 

Running on 64-bit Windows 10 (2004), build ...
(more)
yulim gravatar imageyulim ( 2021-04-08 06:10:43 +0000 )edit

You're running quite an old version of Wireshark that is no longer supported (see the Wiki LifeCycle page). You're also running a known problematic version of npcap that was installed by that version of Wireshark.

Please install the latest stable release and check if that resolves your issue.

grahamb gravatar imagegrahamb ( 2021-04-08 08:21:49 +0000 )edit

now the version is 3.4.4 but it is the same.

Version 3.4.4 (v3.4.4-0-gc33f6306cbb2) 

Copyright 1998-2021 Gerald Combs <[email protected]> and contributors. License GPLv2+: GNU GPL version 2 or later <https://www.gnu.org/licenses/gpl-2.0.html> This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

Compiled (64-bit) with Qt 5.15.1, with libpcap, with GLib 2.52.3, with zlib 1.2.11, with SMI 0.4.8, with c-ares 1.15.0, with Lua 5.2.4, with GnuTLS 3.6.3 and PKCS #11 support, with Gcrypt 1.8.3, with MIT Kerberos, with MaxMind DB resolver, with nghttp2 1.39.2, with brotli, with LZ4, with Zstandard, with Snappy, with libxml2 2.9.9, with QtMultimedia, with automatic updates using WinSparkle 0.5 ...
(more)
yulim gravatar imageyulim ( 2021-04-08 08:40:35 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-04-08 09:28:11 +0000

grahamb gravatar image

You're still running an outdated version of npcap (from your info: with Npcap version 0.995).

The new install of 3.4.4 should have updated that, but you either didn't install the newer npcap, or it failed. Try the following:

  1. Download the latest version of npcap from their site.
  2. Reboot, do not run anything after the reboot.
  3. Install the newly downloaded version of npcap.
edit flag offensive delete link more

Comments

I did. Now I can see the interfaces. Thank you:)

yulim gravatar imageyulim ( 2021-04-09 00:41:36 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-08 05:58:25 +0000

Seen: 229 times

Last updated: Apr 08