Ask Your Question
0

dll dissector won't work with newer version

asked 2020-12-09 15:22:15 +0000

updated 2020-12-09 15:24:26 +0000

Hi, I have a dll dissector on wireshark version 2.4.0, but when I upgrade wireshark to the newest version, it's just won't work and make some errors... How can I make it compatible? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-09 16:12:24 +0000

cmaynard gravatar image

In all likelihood various APIs have changed and you will need to modify your dissector to work with the new version. Without knowing the exact errors you're seeing, you'll just have to work through them one at a time.

Try starting with a re-read of the documentation such as the Wireshark Developer's Guide as well as the various README files, i.e., README.developer, README.dissector, README.plugins, etc. You have full access to all the source code, so you should be able to use other dissectors as guides in porting your dissector to the new version too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-09 15:22:15 +0000

Seen: 39 times

Last updated: Dec 09 '20