Ask Your Question

Revision history [back]

My guess is that the Ethernet dissector is disabled. You can verify if this is the case or not via "Analyze -> Enabled Protocols -> Ethernet", and enable it if it isn't. You can also check if there are other protocols disabled, either in that same dialog or by examining the contents of the disabled_protos file in your profile's directory. If you haven't created a profile, then the Wireshark Default profile is in use. You can locate the directory for all of your Wireshark preferences via "Help -> About Wireshark -> Folders -> Personal configuration", and if you don't want any dissectors to be disabled, you can even just delete the disabled_protos file.

If it was the case that a dissector or dissectors were disabled and you didn't disable them yourself, then it's possible someone was playing a practical joke on you.