Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I don't need monitor mode to see radio packet headers, I'm interested only on data regular packets.

Make sure you turn monitor mode off (the Wi-Fi adapters on newer Macs require that you disassociate from a wireless network network in order to capture in monitor mode, otherwise it doesn't give you any packets). Select Capture > Options, look for en0 in the list, and make sure the checkbox in the Monitor column is not checked.