Hi!

I have a pci atheros card AR5212/AR5213 (rev 01) with madwifi driver and ubuntu 11.10. I installed wireshark 1.6.2. I created an interface in monitor mode but wireshark doesn't see it in monitor mode (the check box is grey).

Could you please help me?

Sboong

PS. This card works great with kismet.

asked 16 Nov '11, 12:56

_sbOOng_'s gravatar image

_sbOOng_
1111
accept rate: 0%

Did you happen to find a solution to your problem? I am experiencing the same things. Only i am trying to use ath5k.

(23 Jan '12, 08:02) red

Just try capturing on the monitor device without checking the monitor mode box. Checking the monitor mode box causes Wireshark to ask libpcap to set up monitor mode; in Linux distributions where libpcap is not linked with libnl, which includes Debian and its derivatives such as Ubuntu, that doesn't work with libpcap 1.1.0 or 1.1.1, as provided with Ubuntu. Therefore, you need to run airmon-ng to set up the monitor device (as libpcap isn't linked with libnl, it won't set up the monitor device itself) and, as the monitor device is already in monitor mode, there's no need to have Wireshark ask libpcap to put it into monitor mode and, in fact, libpcap's attempt to do so won't work.

link

answered 23 Jan '12, 15:05

Guy%20Harris's gravatar image

Guy Harris ♦♦
11.6k227146
accept rate: 18%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6

Asked: 16 Nov '11, 12:56

Seen: 1,512 times

Last updated: 23 Jan '12, 15:05

powered by OSQA