OSQA is unmaintained. Help us figure out where to go from here.

I use command ping 192.168.2.10 -n 1 to test net connection in windows cmd. Simultaneous use wireshark to see what happend. As I think there should be a echo request and a echo replay,but actually saw two echo request and one echo replay,lieke this:

alt text

The first request shows "no response found" and second shows "reply in 338", while in cmd.exe ping shows ok:

alt text

How does this happened?

environment:

win10 64bit + wireshark 2.26

append:

I tried in Linux with the samee version wireshark and it shows only one request and one reply. So I think it should related to my PC, but I don't know what is the reason ???

asked 16 May, 01:02

oska874's gravatar image

oska874
613
accept rate: 0%

edited 16 May, 19:33

I've tried to recreate this myself but have been unable to do so with Windows 10 version 1703 (OS Build 15063.296)

(16 May, 08:17) dbAtAffirmed

Can you upload the corresponding PCAP?

(16 May, 08:34) dkomna

Select one of therequests and have alook in the Packketdetail pane and expand the frame section. There is an attribut called interface. Does it show in both requests the same value?

(18 May, 13:30) Christian_R
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×42

question asked: 16 May, 01:02

question was seen: 216 times

last updated: 18 May, 13:30

p​o​w​e​r​e​d by O​S​Q​A