OSQA is unmaintained. Help us figure out where to go from here.

Hi,

I was using Mavericks on my mac machine and wireshark was running fine on it. Now i updated mavericks to it to Yosemite 10.10. but after updating OS i am not able to launch Wireshark.

I tried both GUI way as well as terminal way but the result is same, Wireshark icon flashes in dock and then goes away.

Please help if any one has launched wireshark on Yosemite.

I removed Wireshark and then re-installed latest version (1.12.0) but no success.

Thanks in Advance :)

asked 03 Sep '14, 23:10

Amit1010's gravatar image

Amit1010
1111
accept rate: 0%

I have the same problem.

(05 Sep '14, 12:46) THN

Xquartz reinstalation has solved the problem for me.

permanent link

answered 06 Sep '14, 14:31

THN's gravatar image

THN
11
accept rate: 0%

edited 06 Sep '14, 14:31

It looks like as part of the Yosemite install; its installer moves all "foreign" files from /usr to /opt - so you end up with X11 in /opt/X11 rather than /usr/X11. I've just reinstalled X11 and it is working now; but it may be that simply a move of /opt/X11 to /usr/X11 will resolve the issue.

permanent link

answered 16 Sep '14, 10:04

OddParityBit's gravatar image

OddParityBit
1
accept rate: 0%

The standard location for Xquartz is under /opt; it's not under /usr because it's not a component of OS X, it's a third-party component (although the "third party" in this case happens to be Apple Inc.). Starting with Mountain Lion, Apple didn't ship X11 as a standard OS component; instead, they offered it through Mac OS Forge. /usr/X11, on Mountain Lion and later, should be a symbolic link to /opt/X11, and Xquartz should be installed in /opt/X11.

(16 Sep '14, 17:44) Guy Harris ♦♦
1

Ar, OK. So, the Yosemite installer deleted the symlink between /opt/X11 and /usr/X11; which my re-install of Xquartz restored.

So, the post-Yosemite fix is likely just "ln -s /opt/X11 /usr/X11"...

(16 Sep '14, 22:22) OddParityBit
1

@OddParityBit this worked for me: ln -s /opt/X11 /usr/X11. I didn't reinstall

(27 Oct '14, 12:41) bhaveshpatel

So, the Yosemite installer deleted the symlink between /opt/X11 and /usr/X11

Probably. I guess it discards /usr and installs the Yosemite version in its place, although supposedly it at least preserves some stuff under /usr; perhaps /usr/X11 isn't something it preserves. (Just /usr/local?)

(27 Oct '14, 14:28) Guy Harris ♦♦

i have try everything you said and write without sucess. Can anyone help me:

I have instaled Xquartz, and wireshark. The wireshark ask me to find the X11, i do that, and the only thing that happens, is the X11 terminal that open.

Thanks in advance. alfredo Almeida

(10 Feb '15, 03:08) Introvertido

I am having the same problem, reinstalled both X11 and wireshark as the link didn't work, still unable to load wireshark after several attempts.

If I run from command line I get this -

2015-05-06 11:09:18.801 defaults[1551:7511] The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist
2015-05-06 11:09:18.809 defaults[1552:7516] The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist
dyld: Library not loaded: /usr/X11/lib/libcairo.2.dylib
  Referenced from: /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin
  Reason: image not found
Trace/BPT trap: 5

any further suggestions??

(06 May '15, 03:22) dalbone

If /opt/X11 doesn't exist, the X11 installation didn't work.

If /opt/X11 does exist, but /usr/X11 doesn't exist, do sudo ln -s /opt/X11 /usr/X11.

If /opt/X11 does exist, and /usr/X11 is a symbolic link to it (ls -l /usr/X11 reports it as a symlink to /opt/X11), then do ls -l /opt/X11/lib/libcairo* and report what it says.

If /opt/X11 does exist, and /usr/X11 exists but is not a symbolic link to /opt/X11, try removing it with sudo rm -rf /usr/X11 and then doing sudo ln -s /opt/X11 /usr/X11.

(06 May '15, 10:44) Guy Harris ♦♦
showing 5 of 7 show 2 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×15

question asked: 03 Sep '14, 23:10

question was seen: 37,872 times

last updated: 06 May '15, 10:44

p​o​w​e​r​e​d by O​S​Q​A