Ask Your Question
0

Windows Build Error

asked 2019-04-09 01:07:33 +0000

Guin gravatar image

updated 2019-04-09 10:06:53 +0000

grahamb gravatar image

I'm working on the build with the following link:

https://www.wireshark.org/docs/wsdg_h...

However, there is a link error during build.

What did I do wrong?

Here is the CMake output message.

-- The C compiler identification is MSVC 19.11.25508.2
-- The CXX compiler identification is MSVC 19.11.25508.2
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.11.25503/bin/HostX86/x86/cl.exe
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.11.25503/bin/HostX86/x86/cl.exe -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.11.25503/bin/HostX86/x86/cl.exe
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional/VC/Tools/MSVC/14.11.25503/bin/HostX86/x86/cl.exe -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Generating build using CMake 3.14.1
-- Found POWERSHELL: C:/Windows/System32/WindowsPowerShell/v1.0/powershell.exe  
-- Building for win32 using Visual Studio 15 2017
Working in C:\Development\wireshark-win32-libs
Tag 2019-04-01 found. Skipping.
-- CMake build type: RelWithDebInfo
-- V: 3.1.0-YourExtraVersionInfo, MaV: 3, MiV: 1, PL: 0, EV: -YourExtraVersionInfo.
-- Performing Test C_Qspectre_VALID
-- Performing Test C_Qspectre_VALID - Success
-- Performing Test CXX_Qspectre_VALID
-- Performing Test CXX_Qspectre_VALID - Success
-- Linker flags: /LARGEADDRESSAWARE /MANIFEST:NO /INCREMENTAL:NO /RELEASE /guard:cf
-- Found Git: C:/Program Files/Git/cmd/git.exe (found version "2.21.0.windows.1") 
-- Found GLIB2: C:/Development/wireshark-win32-libs/vcpkg-export-20190318-win32ws/installed/x86-windows/lib/glib-2.0.lib  
-- Found GMODULE2: C:/Development/wireshark-win32-libs/vcpkg-export-20190318-win32ws/installed/x86-windows/lib/gmodule-2.0.lib  
-- Found GTHREAD2: C:/Development/wireshark-win32-libs/vcpkg-export-20190318-win32ws/installed/x86-windows/lib/gthread-2.0.lib  
-- Found GCRYPT: C:/Development/wireshark-win32-libs/libgcrypt-1.8.3-win32ws/bin/libgcrypt-20.lib (found suitable version "1.8.3", minimum required is "1.4.2") 
-- Found LEX: C:/ProgramData/chocolatey/bin/win_flex.exe  
-- Found YACC: C:/ProgramData/chocolatey/bin/win_bison.exe  
-- Found Perl: C:/Strawberry/perl/bin/perl.exe (found version "5.28.1") 
-- Found Python3: C:/Python37/python.exe (found suitable version "3.7.3", minimum required is "3.4") found components:  Interpreter 
-- Found LIBSSH: C:/Development/wireshark-win32-libs/libssh-0.7.3-win32ws/lib/ssh.lib (found suitable version "0.7.3", minimum required is "0.6") 
-- Found PCAP: C:/Development/wireshark-win32-libs/WpdPack/Lib/wpcap.lib  
-- Looking for pcap_get_selectable_fd
-- Looking for pcap_get_selectable_fd - not found
-- Looking for pcap_set_tstamp_precision
-- Looking for pcap_set_tstamp_precision - not found
-- Looking for pcap_set_tstamp_type
-- Looking for pcap_set_tstamp_type - not found
-- Found AIRPCAP: C:/Development/wireshark-win32-libs/AirPcap_Devpack_4_1_0_1622/Airpcap_Devpack/lib/airpcap.lib  
-- Found MaxMindDB: C:/Development/wireshark-win32-libs/MaxMindDB-1.3.2-win32ws/lib/libmaxminddb-0.lib  
-- Found SMI: C:/Development/wireshark-win32-libs/libsmi-svn-40773-win32ws/lib/libsmi-2.lib  
-- Found GNUTLS: C:/Development/wireshark-win32-libs/gnutls-3.6.3-1-win32ws/bin/libgnutls-30.lib (found suitable version "3.6.3", minimum required is ...
(more)
edit retag flag offensive close merge delete

Comments

I've cleaned up the question by removing the CMakeError.log, as it's usually not relevant.

Your output is odd as it doesn't explain what the errors are. Although it appears that this was a fresh run of CMake, can you delete CMakeCache.txt in the wsbuild32 directory and trying again?

grahamb gravatar imagegrahamb ( 2019-04-09 10:09:10 +0000 )edit

Thank you for the reply.

The above message is a message when the following command is used :

"cmake -G "Visual Studio 15 2017" ..\wireshark 2>&1 >> filename.txt"

I deleted 'CMakeCache.txt' and tried that again, but output message is same.

But there is one thing I overlooked. The following message appeared on the console :

Exception in thread "main" org.jruby.exceptions.MainExitException: unknown encoding name - MS949 list GET given empty list Call Stack (most recent call first): docbook/CMakeLists.txt:14 (find_package)

What does the above message mean? I'll wait for your reply.

Guin gravatar imageGuin ( 2019-04-10 01:01:52 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-10 01:58:50 +0000

Guin gravatar image

I have solved the problem. I read grahamb's comments and tried it again. The problem was in the following message :

Exception in thread "main" org.jruby.exceptions.MainExitException: unknown encoding name - MS949 list GET given empty list Call Stack (most recent call first): docbook/CMakeLists.txt:14 (find_package)

So I set the environment variable "ASCIIDOCTORJ_OPTS = -Dfile.encoding = UTF-8". It has been created since that setting.

I do not know about CMake, So I thought the problem was in 'CMakeError.log'. Thanks to grahamb.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-04-09 01:07:33 +0000

Seen: 43 times

Last updated: Apr 10