Ask Your Question
0

I can't get the eth.ig==0 display filter to work

asked 2018-09-30 13:15:44 +0000

Packetman007 gravatar image

I have a trace of broadcasts and a few unicast destinations. I want to filter to see only the destinations that are not broadcasts or multicasts, only unicasts.

When I filter eth.ig==0 it returns the broadcasts too. It should only return packets that match the filter. I clearly get broadcasts too.

It appear the reason is that this filter is for both source and destination address eth.ig bits.

How do I get it to filter only on what I might think should be: eth.dst.ig==0

Appreciate the help!

Bill

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-09-30 21:16:33 +0000

Guy Harris gravatar image

That works, but we really should make filters such as eth.dst.ig == 0 work.

Please file an enhancement request for this on the Wireshark Bugzilla.

edit flag offensive delete link more

Comments

Indeed, both src and dst are using the same header field definitions for lg and ig bits(which is fine) but should probably have their own src and dst specific ones as well (for all parts of the MAC address).

Jaap gravatar imageJaap ( 2018-10-01 05:34:53 +0000 )edit
0

answered 2018-09-30 13:25:09 +0000

Packetman007 gravatar image

(not eth.dst == ff:ff:ff:ff:ff:ff && eth.ig==0) && (not eth.addr == 33:33:00:01:00:02 && eth.ig==0) This seems to work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-30 13:15:44 +0000

Seen: 35 times

Last updated: Sep 30