Ask Your Question
0

init.lua is not present in the latest wireshark

asked 2024-02-15 17:36:34 +0000

vikas gravatar image

I see there is no init.lua file in the latest wireshark version. 4.2.0 + versions. We usually add some additional files and not we dont know where to add that.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2024-02-17 18:19:30 +0000

johnthacker gravatar image

From this commit, mentioned in the 4.2.0 release notes:

The "init.lua" file is now loaded from any of the Lua plugin directories. Previously it was loaded from the personal configuration directory. (For backward-compatibility this is still allowed; note that deprecated features may be removed in a future release).

There was an issue affecting loading scripts from subdirectories that was fixed in 4.2.1:

From the developer's guide:

If Lua is enabled, Wireshark will first try to load a file named init.lua from the global plugins directory. and then from the user’s personal plugins directory. Then all files ending with .lua are loaded from the global plugins directory. Then all files ending with .lua in the personal Lua plugin’s directory.

Note that the personal plugin location changed around 2.6, though lua plugins, being source and not binary, can be in the older location as well.

To see the list of directories, go to "Help->About Wireshark" and select the "Folders" tab.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2024-02-15 17:36:34 +0000

Seen: 301 times

Last updated: Feb 17