Ask Your Question
0

problem running Wireshark 4.2.0 and 4.2.2 -Windows Server Core 2019

asked 2024-01-07 18:16:01 +0000

jwf gravatar image

updated 2024-01-08 10:33:20 +0000

grahamb gravatar image

installed 4.2.0 on one of my core machines and had an error when I ran Wireshark after; I uninstalled that version and went and installed the update to 4.2.2 -same problem. Any thoughts or guidance? tshark.exe runs and captures fine from cmd prompt.

TIA! w

C:\Users\xxx>"\Program Files\Wireshark\Wireshark.exe"

 ** (wireshark:1704) 12:56:40.115761 [GUI WARNING] -- SetProcessDpiAwarenessContext(DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2) failed: COM error 0x5: Access is denied.
Qt's default DPI awareness context is DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2. If you know what you are doing you can overwrite this default using qt.conf (https://doc.qt.io/qt-6/highdpi.html#configuring-windows)C:\Users\sujwf>

C:\Users\xxx>"\Program Files\Wireshark\Wireshark.exe" -v

C:\Users\xxx>

Wireshark 4.2.2 (v4.2.2-0-g404592842786).

Copyright 1998-2024 Gerald Combs <[email protected]> and contributors.
Licensed under the terms of the GNU General Public License (version 2 or later).
This is free software; see the file named COPYING in the distribution. There is
NO WARRANTY; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (64-bit) using Microsoft Visual Studio 2022 (VC++ 14.37, build 32822),
with GLib 2.78.0, with Qt 6.5.3, with libpcap, with zlib 1.3.0, with PCRE2, with
Lua 5.2.4 (with UfW patches), with GnuTLS 3.8.2 and PKCS #11 support, with
Gcrypt 1.10.2-unknown, with Kerberos (MIT), with MaxMind, with nghttp2 1.57.0,
with nghttp3 1.0.0, with brotli, with LZ4, with Zstandard, with Snappy, with
libxml2 2.11.5, with libsmi 0.5.0, with QtMultimedia, with automatic updates
using WinSparkle 0.8.0, with AirPcap, with Minizip, with binary plugins.

Running on 64-bit Windows Server 2019 (1809), build 17763, with Intel(R) Xeon(R)
CPU E5-2650 v4 @ 2.20GHz (with SSE4.2), with 8191 MB of physical memory, with
GLib 2.78.0, with Qt 6.5.3, with Npcap version 1.78, based on libpcap version
1.10.4, with PCRE2 10.42 2022-12-11, with c-ares 1.19.0, with GnuTLS 3.8.2, with
Gcrypt 1.10.2-unknown, with nghttp2 1.57.0, with nghttp3 1.0.0, with brotli
1.0.9, with LZ4 1.9.3, with Zstandard 1.5.2, without AirPcap, with
LC_TYPE=English_United States.utf8, binary plugins supported.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2024-01-08 07:19:21 +0000

Guy Harris gravatar image

This is probably an annoying issue with Qt, which is the GUI toolkit Wireshark uses (so that it can run on Windows, macOS, and various UN*Xes, such as Linux, that use X11 or Wayland as the GUI base).

Please report this as an issue on the Wireshark issue list. Plus include the full error message from the log.

edit flag offensive delete link more

Comments

sorry to not get back about this before now- it does sound like a Qt issue but that "Access is denied" message makes me wonder if it is something specific to our environment. I've tried setting some environment variables and using the qt.conf file but have had no luck. These machines are VMs running on VMware with current VMware Tools installed

Is there anyone who sees this error on Windows server core machines? I'm seeing it on 2016 and 2019

jwf gravatar imagejwf ( 2024-01-19 17:32:48 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2024-01-07 18:16:01 +0000

Seen: 460 times

Last updated: Jan 08