Can't apply filters by right-clicking

asked 2023-03-08 13:09:24 +0000

Peregrino69 gravatar image

updated 2023-03-08 16:47:28 +0000

  • Wireshark 3.4.10 (Git v3.4.10 packaged as 3.4.10-0+deb11u1)
    • Debian Bullseye up-to-date

When I've used Wshark on Windows, I've been able to create display filters by right-clicking on the Protocol field on the capture, and choosing Apply as Filter. This isn't working, it's greyed out on the right-click menu. Likewise Prepare as a Filter is grayed out.

Right-clicking the protocol in the packet details works; I can both Apply and Prepare Selected and Not Selected.

This Wshark version is installed from Debian (stable) repositories with apt. I've no clue what Wshark version I was using on Windows - I left Win world several years ago, and don't ATM have a test PC or even a Virtual Machine running Windows.

Thank you for the contributions. I found an updated version in Debian resources, but it's an upstream version which I need to build from source. Dang... I smell a dependency hell...

edit retag flag offensive close merge delete


13941: "Apply as Filter" is not applicable on all columns

Are you looking at the same capture on both systems?
Does filtering work if you right-click on the protocol line in the packet details?

Chuckc gravatar imageChuckc ( 2023-03-08 13:45:58 +0000 )edit

Unfortunately Wireshark 3.4.10 is quite old, what version were you using on Windows?

grahamb gravatar imagegrahamb ( 2023-03-08 14:31:01 +0000 )edit

Thank you both for your input. I updated the question with answers.

Peregrino69 gravatar imagePeregrino69 ( 2023-03-08 16:32:04 +0000 )edit

WSDG: 2.1.1. Build environment setup
tools/ "should" pull in the dependencies.

Chuckc gravatar imageChuckc ( 2023-03-08 16:54:41 +0000 )edit

LOL - the number one operative word in IT world: "should" :-D Thanks for the link tho' :-)

Peregrino69 gravatar imagePeregrino69 ( 2023-03-08 20:58:43 +0000 )edit