Ask Your Question
0

Help to understand: why webApp sending packets via TLSv1 insteatd of TLSv1.3?

asked 2023-02-17 09:09:39 +0000

Ericklans gravatar image

updated 2023-02-17 09:11:14 +0000

wireshark dump I have problem to linking whatsapp desktop app on Windows 11. On step of linking after QR-code, App trying to load chats via SSL. Normally App connecting via TLSv1.3. Can you answer where I need to look for a problem, on PC TSL 1.0 and v1.1 are turned off. Is it problem on Cisco router or Firewall? linking whatsapp

edit retag flag offensive close merge delete

Comments

Ericklans gravatar imageEricklans ( 2023-02-17 09:12:39 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2023-02-17 09:46:03 +0000

hugo.vanderkooij gravatar image

Please check details of the packet. That is what is proposed by the client. The question WHY is not something Wireshark will be know. That is up to the application and it's config.

edit flag offensive delete link more

Comments

  1. issued connection by Ethernet adapter with Firewall - https://imgtr.ee/i/OiQSL
  2. details of TLSv1 line - https://imgtr.ee/i/OiTA0
  3. retransmitting issue - https://imgtr.ee/i/OiYzF
  4. reset, ack - https://imgtr.ee/i/Oimam

also I've tried via WiFi-adapter (another internet without Firewall) - https://imgtr.ee/i/OirFB where watsapp is working with no problems

Ericklans gravatar imageEricklans ( 2023-02-17 11:09:50 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2023-02-17 09:09:39 +0000

Seen: 125 times

Last updated: Feb 17 '23