Ask Your Question
0

"Missing parameter: -- remote-host" when capturing on default device

asked 2021-06-07 12:03:04 +0000

Jedrzej gravatar image

updated 2021-06-07 22:54:33 +0000

Guy Harris gravatar image

I installed Wireshark 3.2.7 (Git v3.2.7 packaged as 3.2.7-1) through the Pop!_Shop on my Pop!_OS 20.10. The I clicked the blue fin to 'Start Capturing Packets' but nothing was registering, so I stopped it with the red square and then got these errors:

Unexpected error from select: Interrupted system call. Error by extcap pipe: * (process:42459): WARNING *: 10:11:27.596: Missing parameter: -- remote-host

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-06-07 14:00:49 +0000

Chuckc gravatar image

It is best to run as a non-root user which requires an extra setup step:

Installing from debs under Debian, Ubuntu and other Debian derivatives
(see README.Debian in Gitlab)

Once permissions are set, review the Capture section of the User's Guide. Pick an appropriate interface (Section 4.3. Start Capturing)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-06-07 12:03:04 +0000

Seen: 51 times

Last updated: Jun 07