Ask Your Question
0

Promiscuous mode not working on my Wi-Fi network

asked 2020-11-20 08:50:02 +0000

Ender_Neale gravatar image

I have enabled promiscuous mode but I'm still only getting packages for and from me it worked at first but than about 9 hours later i booted up my pc and had a network adapter called loopback ncap and it says it has no internet connection that is about all the info i have so if u know how to fix it please tell

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-20 09:10:49 +0000

Guy Harris gravatar image

Promiscuous mode doesn't work on Wi-Fi interfaces.

The mode you need to capture traffic that's neither to nor from your PC is monitor mode. See the Wireshark Wiki's CaptureSetup/WLAN page for information on this.

Note that, unless your network is an "open" network with no password (which would mean that other people could see your network traffic, so you probably don't want that), you will need to arrange that Wireshark have enough information to decrypt the traffic to and from hosts on a network. See the Wireshark Wiki's HowToDecrypt802.11 page for information on that.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-20 08:50:02 +0000

Seen: 33 times

Last updated: Nov 20