RTP can't be "Decode as" RTP in G711 PCMA [closed]

asked 2020-08-19 06:52:55 +0000

MichelR gravatar image

updated 2020-08-19 08:00:36 +0000

grahamb gravatar image


I have a issue with some VoIP tracefiles,not all, i can't "Decode as" my RTP stream.

  1. i see, after my UDP, ? KNX/IP Unknown Service Family ? KNX/IP Header: Service = 0x11ce ? Unknown data (44 bytes)

  2. ok, i try to apply "Decode as" RTP, but it doen't work. i try again, KO but i see;

Field        Value   Type              Default  Current
UDP port     40026   Integer,base 10   (none)   RTP        (my first try)
UDP port     40026   Integer,base 10   (none)   (none)    (when i try again, the port 40026 is already seen in RTP, but doesn't decode, and this, for each port)

it seems to me that if the SIP exchange is not seen,in my case it's TLSv1.2, the RTP is not decoded naturally? But with some pcapng I didn't have these decoding worries.

My version is 3.2.6 (v3.2.6-0-g4f9257fb8ccc)


Best Regards


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by MichelR
close date 2020-08-20 07:58:57.742221


Answered by Jaap Keuter 2020-08-19 16:48:32 UTC (thanks to him)

Setup Decode As... with these values

Field Value Type Default Current UDP port 40000 Integer, base 10 KNX/IP RTP

For my part, I disabled this protocol to have only UDP. Then I applied "decode as" RTP, it worked.

MichelR gravatar imageMichelR ( 2020-08-20 08:05:54 +0000 )edit