Ask Your Question
0

GSM - Measurement Report decoding problem

asked 2018-02-21 05:49:53 +0000

Nalin gravatar image

updated 2018-02-21 06:51:26 +0000

Jaap gravatar image

Hello,

I am decoding GSM - MEASUREMENT Report and it shows incorrect/unknown value for IE "RXLEV-SUB-SERVING-CELL"

PDU hex: 06 15 bf 7f 7e 00 00 00 00 00 00 00 00 00 00 00 00 00

Decoded output:
    Measurement Results
        1... .... = BA-USED: 1
        .0.. .... = DTX-USED: DTX was not used
        ..11 1111 = RXLEV-FULL-SERVING-CELL: >= -48 dBm (63)
        0... .... = 3G-BA-USED: 0
        .1.. .... = MEAS-VALID: The measurement results are not valid
        ****RXLEV-SUB-SERVING-CELL: Unknown (127)****
        .111 .... = RXQUAL-FULL-SERVING-CELL: BER > 12.8%, Mean value 18.10% (7)
        .... 111. = RXQUAL-SUB-SERVING-CELL: BER > 12.8%, Mean value 18.10% (7)
        .... ...0  00.. .... = NO-NCELL-M: No neighbour cell measurement result (0)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-21 12:43:41 +0000

Anders gravatar image

updated 2018-02-21 12:47:28 +0000

That's a bug, patch inbound. https://code.wireshark.org/review/#/c...

edit flag offensive delete link more

Comments

Thanks Anders, Let me know on which Wireshark Release this fix will be included. Thanks in advance..

Nalin gravatar imageNalin ( 2018-02-22 02:46:30 +0000 )edit

It's in the development version and in the just released 2.4.5

Anders gravatar imageAnders ( 2018-02-23 21:40:35 +0000 )edit

Thanks Anders, I have verified it with this version and its working now.

Nalin gravatar imageNalin ( 2018-02-24 12:58:41 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-02-21 05:49:53 +0000

Seen: 81 times

Last updated: Feb 21