Ask Your Question
0

Wireshark with Lua on RedHat 8

asked 2020-06-16 16:25:33 +0000

updated 2020-06-16 21:47:06 +0000

grahamb gravatar image

RedHat 8 comes with Lua 5.3 and I understand that is not supported, however, I have built Lua 5.2.4 from source and installed as per the instructions on the Lua site but when I try to build Wireshark I get a bunch of errors relating to liblua.a along the lines of:

/usr/bin/ld: /usr/local/lib/liblua.a(ltablib.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

(there's about 20 like this).

I have tried adding the -fPIC flag a dozen different ways through environment variables and also in the Lua Makefile and recompiling both Lua and Wireshark but thus far I have not been able to get past this point.

Does anyone have a good guide how to build Wireshark on Red Hat 8 with support for Lua?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-16 20:07:25 +0000

Well it looks like the make process for Lua was ignoring my environment variables. For future reference and anyone else who comes across this problem the way to do it is to build Lua as follows:

$ sudo yum install readline-devel
$ tar -xvf lua-5.2.4.tar.gz
$ cd lua-5.2.4
$ make Linux MYCFLAGS=-fPIC
$ sudo make install

Then you should be able to make Wireshark no problem

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-06-16 16:25:33 +0000

Seen: 89 times

Last updated: Jun 16