Ask Your Question
0

"Apply as Filter"/"Prepare as Filter" grayed out when selecting second time

asked 2020-04-04 07:55:24 +0000

msc gravatar image

I'm using Wireshark Version 3.0.7 on MacOS.

I select http.request.method in packet details pane with right mouse click on select "Apply as Filter" -> "Selected". This works fine.

Afterwards I clear the display filter and try to do the same as above again. But then all options behind "Apply as Filter" / "Prepare as Filter" are grayed out. I need to restart Wireshark, after that it works again, but only once.

edit retag flag offensive close merge delete

Comments

I've been seeing similar behavior across the different platforms. However, I don't usually have to restart the app - it's enough to click off the field I want, then click back on it, to get the selected menu back. Since I could not replicate on demand - it was always random for me - I did not file a bug. Can you reliably reproduce? If so, I'd file a bug at https://bugs.wireshark.org/bugzilla/.

Bob Jones gravatar imageBob Jones ( 2020-04-04 15:56:53 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-04 20:39:57 +0000

Jaap gravatar image

This seems to be a bug in the 3.0 series of Wireshark. You could consider filing a bug report, but since the 3.0 series will become End-of-Life in a few months I don't know if this is going to be solved. Why not upgrade to the 3.2 series (3.2.2 at the moment)? This doesn't seem to exhibit this behaviour.

edit flag offensive delete link more

Comments

Thanks a lot for the answers. I will update to 3.2 and will check for that behavior.

msc gravatar imagemsc ( 2020-04-06 07:03:23 +0000 )edit

Version 3.2.3 solved this issue. Thanks.

msc gravatar imagemsc ( 2020-04-09 09:30:41 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-04 07:55:24 +0000

Seen: 208 times

Last updated: Apr 06