Ask Your Question
0

Data written to the pipe is neither in a supported pcap format nor in pcapng format

asked 2020-02-02 23:44:04 +0000

kpaitsel gravatar image

updated 2020-02-03 00:15:01 +0000

Guy Harris gravatar image

Help - new to wireshark Data written to the pipe is neither in a supported pcap format nor in pcapng format.

Thanks for any help

edit retag flag offensive close merge delete

Comments

What were you doing when that happened?

Guy Harris gravatar imageGuy Harris ( 2020-02-03 00:15:17 +0000 )edit

i'm having the exact same problem for a Hands On Project for a Networking Concepts course. I'm also a total newb to this and am utterly lost.

You're asked in step 2. "Start Wireshark and click Capture Options. In the Capture Filter text box, type icmp, and then click start."

It is then when I receive an error message stating the above:"Data written to the pipe is neither in a supported pcap format nor in pcapng format. Please report this to the developers of the program writing to the pipe."

Please help.

edh227 gravatar imageedh227 ( 2020-02-06 23:13:49 +0000 )edit

I got same prlblem after I run plink.exe -ssh -pw xxxxx [email protected] "tcpdump tcp -U -s 0 -i eth0 port 80 -w -" | "C:\Program Files\Wireshark\Wireshark.exe" -k -S -i - got the message "Data written to the pipe is neither in a supported pcap format nor in pcapng format. Please report this to the developers of the program writing to the pipe." Waitting for the solution!

thomasliqiang gravatar imagethomasliqiang ( 2020-06-05 04:27:01 +0000 )edit

I met similar problem, when I using plink -ssh remote to a server running dumpcap for remote trace and the wireshark popup this error message, I'm running the wireshark v3.2.4 and putty v7.3. Finally, the problem solved with reinstalling a older version putty v7.0. Or you would just download a plink.exe v7.0 and replacing the v7.3, it is also working properly afterward.

JC gravatar imageJC ( 2020-06-15 09:46:46 +0000 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-24 03:07:42 +0000

updated 2020-07-24 03:28:53 +0000

I have same issue, and solved by using plink.exe 0.70. But I dont't want to use vulnerable version of PuTTY ... I found plink.exe between 0.70 and 0.73 option changes affects default behavior. Finally, I identified required that explicitly disable interactive input as follows:

 -batch

or

-no-antispoof

It works latest 0.74.

see following link more detail

  1. https://tartarus.org/~simon/putty-sna...
  2. https://tartarus.org/~simon/putty-sna...
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-02-02 23:44:04 +0000

Seen: 6,320 times

Last updated: Jul 24