Ask Your Question
0

snmp v3 not decoding properly [closed]

asked 2019-06-25 22:05:02 +0000

psellno gravatar image

Running wireshark 3.0.2 (a new version for me), I have entered the snmp v3 username and credentials, same as I have successfully done on previous versions of wireshark, but I am getting "Decrypted data not formatted as expected". I have checked, double checked, and triple checked the credentials (even tried converting them to hex and entering them as hex strings), but it still doesn't work. Is there any known snmp v3 bug in the 3.0.2 release?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Guy Harris
close date 2019-06-26 17:45:09.945838

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-06-26 17:09:23 +0000

psellno gravatar image

My apologies, operator error, I had left off a digit on one of the passwords. It is working fine.

edit flag offensive delete link more
0

answered 2019-06-26 01:23:55 +0000

Guy Harris gravatar image

If there is a known bug, it'll be in the Wireshark Bugzilla.

If there isn't one, please file one there; that, not the Q&A site, is the best place to report bugs.

If you think 3.0.2 isn't decrypting files that earlier versions did dissect - you might want to try installing an older version to see what it does with that file - then you probably have a bug to report.

If no version decrypts that particular capture, that might be a long-standing bug, or it might be an issue with the network traffic; the best way to get that resolved is to file a bug.

edit flag offensive delete link more

Comments

Works fine for me (using SHA1 and AES) so be very specific in your bug report as to what you do and illustrate with a proper sample capture file (not screenshots!)

Jaap gravatar imageJaap ( 2019-06-26 09:55:21 +0000 )edit

Question Tools

1 follower

Stats

Asked: 2019-06-25 22:05:02 +0000

Seen: 87 times

Last updated: Jun 26